[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: The case of the read-only USB sticks.

On Sat, 22 Feb 2014 17:18:11 +0000, Hendrik Boom wrote:

> On Sat, 22 Feb 2014 16:38:34 +0200, Andrei POPESCU wrote:
>> On Sb, 22 feb 14, 14:33:24, Hendrik Boom wrote:
>>> I have a problem with my USB sticks mysteriously becoming read-only.
>> You didn't provide any information about make, model, size,
>> partitioning, file systems, etc. Also the relevant lines from syslog
>> when you plug in the stick are very useful for diagnosing.
>> Kind regards,
>> Andrei
> Thank you.  I will investigate and provide syslog data for the old read-
> only sticks and the new writable ones when I get the chance.
> Of the old USB sticks -- the ones that turned read-only -- I currently
> am in possession of only one, and it worked fine  this morning if I am
> root when I mount it and write it.  It's labelled Lexar USB3.0 64G.  I
> haven't tried it on my wife's Mac since.
> If I have to be root, perhaps it's some mount permission problem I'm
> getting.
> Of course it could be that I missed this one stick when I was trying the
> old failing sticks last week and it's been OK all along.  Im going to
> have to keep careful records.
> The others I handed to a friend a few days ago, who said he wanted to
> try them out on his equipment.  I'll see them again next Wednesdays.
> -- hendrik

I think I may have a solution.  I suspect the problem is with improperly 
unmounted/ejected (teminology varies) USB sticks.  On some systems it can 
be hard to figure out the proper unmounting protocol.

But when I mount such a stick on Debian, it gets mounted at best as read-
only.  And often it does it automatically, and as root instead of as the 
user currently logged in (assuming there is only one)

I have to check if it's mounted, and unmount it as root.  Then to do an 
fsck -a -y so that it will indeed fix problems.  Usually the only problem 
is that a flag has been said telling me it hadn't been properly unmounted 
last time it was used.

-- hendrik

Reply to: