[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debian on a Dell Latitude E7440

I have an E7420 running Debian on it for work. The 7.4 ISO was plenty to get it working and I used UEFI as well with GRUB bootloader. I did have to upgrade it to testing (jessie) however to get all the devices working and get the newer XORG that would support the graphics card. I don't have it with me currently or I could check further details but catch me during the work day and I can assist.

On 01.07.2014 18:35, Craig L. wrote:
On Tue, Jun 24, 2014 at 12:25:21PM -0400, ken wrote:
On 03/22/2014 01:29 PM Craig L. wrote:
>.... I found folks
>running other distros on the E7440, so we're going with it. If I have any >problems I will pass them along for anyone else that is interested in this.

One of the nice things about GNU/Linux is that, if one distro works
on a particular machine, then it's at least theoretically possible
for all other GNU/Linux distros to work on it.  After all, it all
comes down to the code.  When this wouldn't be true would be when,
for example, some distro (and there are a lot of them) used
proprietary, non-FOSS code for a driver.  From my understanding,
Debian in particular shuns non-FOSS software, so such an instance
would be problematic.

How has the E7440 been working out?  Any of the hardware not
recognized or not functioning as expected?

Hi Ken

Pretty good timing on your part, and thanks for cc'ing me in. My ISP
seems to have banned me from receiving user list emails.

We received the laptops last week and other than a few minor things I
have it working. I have not installed a GUI yet, but expect no real
issues there.

First of all, I tried to install from a debian-7.3.0-amd64-DVD-1.iso
image, using uefi install, but network hardware was not detected.
the debian-7.5.0-amd64-DVD-1.iso image worked just fine. But apparently the lilo bootloader won't work with UEFI, and I hate grub, so I had to disable that in the BIOS. Other than that, the only other issue was the
wireless card. It is an Intel Centrino WiMax 7260, or something like
that. The firmware that was installed did not contain a driver for it, and it requires the non-free iwlwifi driver. The version of the driver
that supports this card had to come from jessie, firmware-iwlwifi

I downloaded that .deb and extracted it, then copied the pertinent driver files to /lib/firmware, and loaded the iwlwifi module using modprobe, but the interface would not show up. Then I had an “aha!” moment and figured
the kernel may not support that driver. So I installed the lates 3.14
kernel from backports, rebooted, and there was my interface. I have
successfully configured it using wpa_supplicant to connect to our
enterprise wireless network.

I plan to install the XFCE DE, but I have no qualms that I will get that taken care of. For the most part this laptop will be used by me to access my workstation when I am in meetings and such, so I will probably also make use of the display port output too. That may prove to be a bit more of a challenge. I will report back with any issues, but for now consider
no news to be good news.

Please cc me in on replies since I no longer receive list mailings.


Reply to: