[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Getting snd_cs46xx working with wheezy

lspci lists my 1013:6003 sound card as,

01:0a.0 Multimedia audio controller: Cirrus Logic CS 4614/22/24/30 [CrystalClear SoundFusion Audio Accelerator] (rev 01)

I tried following the instructions at https://wiki.debian.org/snd-cs46xx
but found that the link to cs46xx_image.h is broken. I instead used the
latest copy of it from git://git.alsa-project.org/alsa-firmware.git so
perhaps the wrong version, though the patching seemed to go okay.

Booting after this installation process does achieve for me a pleasing,

snd_cs46xx 0000:01:0a.0: firmware: agent loaded cs46xx/cs46xx-old.fw into memory

and I actually get an entry in /proc/asound/cards,

 0 [CS46xx         ]: CS46xx - Sound Fusion CS46xx
                      Sound Fusion CS46xx at 0xfeafe000/0xfe900000, irq 17

but the syslog also carries messages like,

AC'97 write problem, codec_index = 0, reg = 0x12, val = 0x861f
AC'97 write problem, codec_index = 0, reg = 0x12, val = 0x8606
AC'97 write problem, codec_index = 0, reg = 0x12, val = 0x606

and if I try to actually play any sound then it doesn't work and syslog
accumulates entries like,

snd_pcm_update_hw_ptr0: 75 callbacks suppressed
snd_pcm_update_hw_ptr0: 74 callbacks suppressed

I tried building from the alsa-firmware git checkout directly but after
some wrestling with autoconf I couldn't get a cs46xx-old.fw out of it
(which is perhaps expected).

Does anybody have such a card working with wheezy? What is the secret to
obtaining working firmware / ALSA configuration?

-- Mark

Reply to: