[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Network Performance Degrading over random amount of time



Hi

On Sun, Apr 20, 2014 at 01:01:53PM +0200, h@xx0r.eu wrote:
> Hi List,
> maybe you have a clue about the issues im having since several months.
> My Homeserver is running Debian Jessy right now, the network issues
> where there with wheezy aswell.
> after a fresh boot my network behaves like it should archiving near
> gbit speeds which is nice, after a random amount of uptime though my
> throughput degrades below 100mbit network speeds (about ~3.5MB/s)
> i measured using iperf.

You don't explicitly say... Does a reboot "cure" the problem (temporarily?)

If so, does a "ifdown eth0"[1] + "ifup eth0" have the same effect?  (if
necessary: Unplug and re-plug the cable between "ifdown" and
"ifup"...)  [A full reboot is a bit like a sledge hammer... very
crude]

>From the point-of-view of the switch, this should be almost
indistinguishable from a full reboot...

Anything in the kernel message log? (e.g. output of "dmesg" or
/var/log/kern.log) It would be interesting if the kernel spat out some
messages around the time of the degradation...  E.g. link-level
renegotiation or similar.

Also: Anything interesting in the output of "ifconfig eth0" ?  I'm
particularly interested in the counters for errors, dropped, overruns,
frame/carrier counts: These counters may show interesting changes
around the time of the degradation...

> 
> Current Hardware:
> 
> - Asus P8H67-M PRO
> - Intel(R) Core(TM) i3-2100 CPU @ 3.10GHz
> - 16 GB DDR3 Ram (2*8GB Kingston ram)
> - Intel Corporation 82541PI Gigabit Ethernet Controller
> - TP-Link 8-Port gbit switches (2 of em between home-server and clients)

*two* switches between server and clients?  Sounds a bit unusual - at
least for a home set-up...

> Ive tried diffrent things so far:
> 
> - Switched from a switched cabling setup to Crosslink.

Hm... AFAIK modern network cards tend to adjust themselves to both
"normal" and cross-over cables (which I believe that "crosslink"
means).

> - Swapped out the cheap asrock motherboard with asus
> - Changed from onboard realtek network chip to PCI Intel Gbit card

Hm.. That would likely rule out any network card issues.

> - Reinstalled OS several times

.. which would most likely rule out any OS bugs. But not administrator
configuration mistakes...

> - Testing from diffrent clients (Win 7, Linux Mint, Debian, Ubuntu)

... which would then most likely rule out administrator mistakes: Win7
is sufficient differently from anything else to make it difficult to
make the same mistake across platforms.

> - Downloading vendor drivers and using them instead of the kernel
> inbuild ones
> 
> Nothing so far had worked to get my gbit speeds stable over a few days.

When you measure the speed, between which two points do you measure
the speed?

I'm concerned about the TWO TP-Link switches: The diagnostics you have
done so far does not appear to rule them out.... Does your traffic
have to pass through both of them?  If so, how are they switches
connected?

Based on what you have written, my main suspects would be the two
switches - with a focus on the "nearest" switch...

> im open to ANY suggestions here even if they involve building a
> custom kernel or other magical hakkery ;D

Well - it looks like you have put a fair amount of effort into solving
this.... But until the problem is narrowed down, this would probably
be as likely to resolve the problem as a goat sacrifice ... You
haven't got a spare goat[2], have you? :-)

Hope this helps

[1] I'm assuming eth0 here....
[2] A live one would constitute a "hot spare", right?  Yeah. Tangent.

-- 
Karl E. Jorgensen


Reply to: