[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

gdm does not start; lost networking

I thought I had a good system. I was installing software from tarballs and putting them in /usr/local/. That worked well. Yesterday, I tried to install various versions of pcb-20110918. Among the commands I executed were

sudo apt-get install libglw1-mesa-dev freeglut3-dev libgtkglext-dev libgd2-xpm-dev

I am pretty sure that is all I did. After that, pcb-20110918 installed. I moved onto ngspice-23, ngspice-25, xspice-1. ngspice-25 ended up building. In the mean time, I executed the following:
sudo apt-get update
sudo apt-get install build-essential linux-headers-`uname -r`
sudo apt-get install libtool automake autoconf
sudo apt-get install flex bison texinfo
sudo apt-get install libx11-dev libxaw7-dev

All applications worked. I shutdown the machine. This morning, gdm would not start and I don't have any networking.

Since the things I want to keep are located in /usr/local and in ~/HOME what would be the recommended way to reinstall gdm? Is it as simple as adding DVD's to the apt source list and running
sudo apt-get install gdm
I would probably do the same to get networking up and running.

Looking for advice. I have the feeling I am not the first person to do this.


Reply to: