[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Can;t fix doc-base installation problem



Hi everyone:

I've had to restore one of my systems from cold iron. Aptitude seems to be hanging up when trying to install / purge / update doc-base. I've tried Aptitude, dpkg and apt-get including the -f switch with no  joy. Below is a typical example:

root@mycomputer:/home/gary# aptitude purge doc-base
The following packages will be REMOVED: 
  doc-base{p}
0 packages upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
Need to get 0 B of archives. After unpacking 504 kB will be freed.
Do you want to continue? [Y/n/?]
(Reading database ... 297009 files and directories currently installed.)
Removing doc-base ...
cannot find install-docs on path
dpkg: error processing doc-base (--purge):
 subprocess installed pre-removal script returned error exit status 1
configured to not write apport reports
                                      Errors were encountered while processing:
 doc-base
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install.  Trying to recover:
                                        
root@mycomputer:/home/gary#

I have tried cleaning and reloading the archives. That didn't help. The whole dpkg process seems to be hung up at this point. If I try to process any other packages, the installation process always returns to some variation of the above. The package seems to be partially installed. The C flag is set in aptitude. A not configured error is sometime displayed. Any suggestions?

Thanks in advance

Gary R.




Reply to: