[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: trouble getting apt-pinning to work

Further troubleshooting info:

I ran apt-get policy and it appears my preferences aren't getting
picked up. Does anyone know why this might happen, or what can be done
to force the preferences file to reload?

apt-cache policy
Package files:
 100 /var/lib/dpkg/status
     release a=now
 500 http://ftp-mirror.internap.com/pub/debian/ wheezy/contrib amd64 Packages
     release o=Debian,a=testing,n=wheezy,l=Debian,c=contrib
     origin ftp-mirror.internap.com
 500 http://ftp-mirror.internap.com/pub/debian/ wheezy/main amd64 Packages
     release o=Debian,a=testing,n=wheezy,l=Debian,c=main
     origin ftp-mirror.internap.com
 500 http://ftp-mirror.internap.com/pub/debian/ squeeze/contrib amd64 Packages
     release v=6.0.6,o=Debian,a=stable,n=squeeze,l=Debian,c=contrib
     origin ftp-mirror.internap.com
 500 http://ftp-mirror.internap.com/pub/debian/ squeeze/main amd64 Packages
     release v=6.0.6,o=Debian,a=stable,n=squeeze,l=Debian,c=main
     origin ftp-mirror.internap.com
Pinned packages:

On Thu, Nov 8, 2012 at 4:07 PM, Brendan Miller <catphive@catphive.net> wrote:
> I'm on debian stable (squeeze), but would like to be able to install a
> few packages from testing (wheezy). I tried to set up apt pinning, but
> it doesn't seem to work quite right. When I apt-get install something
> now, it all comes from wheezy even if there are squeeze versions of
> the package. It's almost like the preferences file isn't getting read.
> Is there anything wrong with the configuration below? Is there any way
> to get apt to spit out it's internal model of the priorities so I can
> verify that everything is actually getting loaded?
> /etc/apt/preferences:
> Package: *
> Pin: release a=squeeze
> Pin-Priority: 700
> Package: *
> Pin: release a=wheezy
> Pin-Priority: 650
> /etc/apt/sources.list:
> # Debian packages for squeeze
> deb http://ftp-mirror.internap.com/pub/debian/ squeeze main contrib
> # Wheezy
> deb http://ftp-mirror.internap.com/pub/debian/ wheezy main contrib

Reply to: