[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug reporting for powerpc - partition not found


I tried installing debian onto an imac G3, and after the install completes, the hard drive or partition is not accessible and it drops to a shell in initramfs.

Using debian-6.0.6-powerpc-CD-1.iso

I am not sure what package this is, as it could be the kernel or the initrd as far as I can tell.

Similar to Bug #352946

The hardware is iMac G3 600MHz SE,
Model No: M5521, manufactured early 2001.
Full hardware info can be found at http://www.everymac.com/systems/apple/imac/specs/imac_se_600.html

Before the error message there were two errors: the first is also seen in the above bug report:
FATAL: Error inserting i8042 (/lib/modules/... ... ...serio/i8042.ko): No such device

Then the next error references a file relating to my keyboard, I don't remember the full name but it was something along the lines of *kbd.* (I have a standard USB keyboard plugged into the iMac as a note)

The error message is something like "ALERT! /dev/disk/by-uuid... does not exist. Dropping to a shell!"

The installer placed the system on partition 3, so I tried changing the boot parameter of yaboot from "Linux" to "Linux root=/dev/hda3" but the /dev/ directory only has /dev/hda, and no partitions are specified.  Also, the /dev/disk folder on the initramfs only has /by-id/ and /by-path/, and no folder for by-uuid.  Additionally, the folder for /by-id/ lists both the hard drive and cd drive, while the /by-path/ only shows one item, presumably the CD drive.

If anybody has done this, perhaps since this is a 11 year old machine, perhaps an earlier version of debian will work with that model?

Thanks for advice,


Reply to: