[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Help with KVM/libvirt/win2008r2. Guest loosing time.

I have a Win 2008 R2 guest running under KVM controlled by libvirt.  The
guest is loosing time.  I have the clock open on the guest and the seconds
change once every 2-5 seconds.  The guest was started at 11:45:58.  As of
13:10:30 the guest's time is 12:03:46.

I have tried various things that I found on google.  Unfortunately, the
sites I found do not work for me.

I've tried setting the machine type to pc-0.13 (default pc-1.1), -no-hpet,
-no-kvm-pit-reinjection, -rtc clock=host, -rtc driftfix=slew, different CPU
options and combinations of those.

Here is the KVM line that libvirt used:
LC_ALL=C PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
HOME=/ QEMU_AUDIO_DRV=none /usr/bin/kvm -S -M pc-0.13 -cpu core2duo
-enable-kvm -m 2048 -smp 1,sockets=1,cores=1,threads=1 -name tcc2008
-uuid b8c797af-8b7e-4d54-cf0a-c21eea23f5c7 -nodefconfig -nodefaults
-chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/tcc2008.monitor,server,nowait
-mon chardev=charmonitor,id=monitor,mode=control
-rtc base=localtime,clock=host -no-hpet -no-kvm-pit-reinjection -no-shutdown
-boot order=cdn,menu=on
-device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2
-drive file=/vm/tcc2008/tcc2008.img,if=none,id=drive-virtio-disk0,format=qcow2,cache=none
-device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x4,drive=drive-virtio-disk0,id=virtio-disk0
-drive if=none,id=drive-ide0-1-0,readonly=on,format=raw,cache=none
-device ide-cd,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0
-netdev tap,fd=24,id=hostnet0,vhost=on,vhostfd=25 
-device virtio-net-pci,netdev=hostnet0,id=net0,mac=52:54:00:f4:f2:ec,bus=pci.0,addr=0x3
-chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=serial0
-device usb-tablet,id=input0
-vnc,password -vga std
-device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x5

NOTE: The command above was split at options to make readability easier.

qemu-kvm: 1.1.0+dfsg-1 64-bit
Kernel is vanilla 3.4.2

Reply to: