[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: problem with video display in X

On Fri, 04 May 2012 12:54:45 -0400, Long Wind wrote:

> i have just installed Debian 6
> it has problem with my video card
> i have to set to 15 bit with /etc/X11/xorg.conf if i use 16 bit or 32
> bit, the monitor shows incorrectly and i have to press power button to
> shutdown

Please, attach/upload your "/etc/X11/xorg.conf" configuration file.

> I attach /var/log/Xorg.0.log
> (now I go to sleep. (I will replay later, Thanks!))

Thanks, I put here what I find relevant (in no special order):

(--) PCI:*(0:1:0:0) 1002:5446:1002:0008 ATI Technologies Inc Rage 128 Pro 
Ultra TF rev 0, Mem @ 0xd8000000/67108864, 0xdfdfc000/16384, I/O @ 
0x0000a800/256, BIOS @ 0x????????/131072

Okay, that's your VGA. Quite old, right? :-)

(WW) R128(0): Can't determine panel dimensions, and none specified.
	Disabling programming of FP registers.
(WW) R128(0): Direct rendering disabled

(EE) R128(0): No DFP detected
(EE) R128(0): [dri] R128DRIScreenInit failed (depth 15 not supported).  
[dri] Disabling DRI.

Those warnings and errors could be becasue of bad/wrong settings in the 
xorg.conf file. What I would do is:

1/ Rename your current "/etc/X11/xorg.conf" to "/etc/X11/xorg.conf.orig" 
and let Xorg to make an educated guess on your VGA.

2/ If the above does not work, you can try to reconfigure Xorg again 
(dpkg-reconfigure -phigh xserver-xorg).

Before doing anything, be sure to have a copy of the current working "/
etc/X11/xorg.conf" file and put it in a safe place, just in case.



Reply to: