[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Wicd and WPA2 password error: a bizarre fix

Hello, all:

I just installed a new testing system (Lenovo ThinkPad L512, recently
Wooted for $500), using the xfce installation option. It uses wicd
instead of network-manager by default, so I decided to try it. My
wired connection worked immediately, but at first wireless wasn't even
turned on. During installation, I had been prompted for a couple of
non-free drivers that I did not have available and so I installed them
after the fact (firmware-iwlwifi and firmware-realtek). Still wireless
was not turned on. For whatever reason (perhaps because wireless was
not functional when I first booted up), /etc/wicd/manager-settings.
conf had nothing in the "wireless_interface = " line, so I added
"wlan0" and rebooted; wireless was now active.

Now the real fun begins. I try to connect to my wireless network,
which uses WPA Personal (PSK) + AES (so Tomato on my Linksys WRT54GL
tells me). So, in the Wicd Network Manager, I chose WPA 1/2
(Passphrase) for my network and entered the correct passphrase
(although Wicd is calling it a "Shared Key"). When I try to connect, I
get a "Connection Failed: Bad Password" error. Much Googling reveals
that this is not a new problem but a persistent one, years old in
fact, and incredibly still not fixed. Apparently the culprit is
wpa_supplicant which wicd uses as a backend. As a last resort, before
dumping wicd and installing network-manager (which I have never had
any troubles with, which I know is not the universal experience with
it) I tried entering my passphrase (which has numbers and upper and
lower case letters in it) using WPA 1/2 Hex ([0-9/A-F]). IT WORKED!!!!
Ridiculous, I know, but I am now connected to my wireless network.

I report this in hopes that others might not have to waste all the
time I just wasted getting it to work. Now I'm just hoping that wicd
can handle VPN, which network-manager does flawlessly.


Reply to: