[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Laser Printer printing intermittantly, CUPS bug?

* Johann Spies <jspies@sun.ac.za> [120412 07:22]:
> On Thu, Apr 12, 2012 at 09:11:03AM +0200, John Magolske wrote:
> >     W [11/Apr/2012:23:36:00 -0700] Avahi client failed: -26
> > 
> > Any thoughts as to why printing is not working here?
> I don't know much about avahi, but if you read the package description
> of something like 'Avahi Daemon' you will see that if something is wrong
> with the avahi-process that would probably explain your problem.  Read
> about avahi and check whether the related processes are running.

Thanks for the reply.

Reading the following leads me to believe avahi-daemon needs to be
running for cups to work:

    ...didn't realize that I had to start dbus and avahi-daemon manually.
    I added both to my /etc/rc.d and ran them manually with:
    rc.d start dbus
    rc.d start avahi-daemon

When booting up I see this message:

    Starting Avahi mDNS/DNS-SD Daemon: avahi-daemon failed!

and when I try to start avahi manually as root:

    # avahi-daemon
    Found user 'avahi' (UID 108) and group 'avahi' (GID 110).
    Successfully dropped root privileges.
    avahi-daemon 0.6.31 starting up.
    dbus_bus_get_private(): Failed to connect to socket
    /var/run/dbus/system_bus_socket: No such file or directory
    WARNING: Failed to contact D-Bus daemon.
    avahi-daemon 0.6.31 exiting.

I have tried several PPD files including the one from Brother. Haven't
tried the Gutenprint driver, may try that next. But I'm thinking
getting the avahi-daemon running may be the issue. Perhaps I need to
get dbus running first? Any suggestions as to what I might need to
fix / configure?


John Magolske

Reply to: