[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

scsi Install problem



I am trying to reinstall an older machine with an Advansys SCSI host adapter and not having much luck. I have two of the same model adapters and both have the same issues. When I boot without either in the machine, it gets well past my error/stopping point.

I'm booting off of the CD 1, I downloaded it 2 days ago, its worked with another box I reinstalled yesterday (replacing a sarge install, cleaning out the basement). I've tried different options expert install and rescue, etc and they all seem to go awry just after the kernel boots, it recognizes all the hardware including the scsi adapter. But at some point there is a scsi bus reset warning then it never seems to complete, it just keeps resetting and failing. The errors messages cycle and repeat:

scsi host0: error: init_state 0x1f, warn 0xfffe, error 0x0
firmware: requisting advansys/mcode.bin
Failed to load image "advansys/mcode.bin" err -2
scsi 0:0:0:0: SCSI bus reset started...

The internet seems to say this is a firmware issue, and suggests obtaining mcode.bin and place it where debian expects it to be, but I don't know where that is (on my laptop I assume /lib/modules/2.6.32-5-686/kernel/drivers/scsi/), but it would be a little hard to place it since this is the install CD and not an existing system. Can I mount the CD image and just add the file and burn it to disk? Would I put the file in a directory or would the installer expect it to be bundled in a deb/udeb file? Even so the internet also seems skeptical that this will actually work, but I couldn't find any reason why that is. Thanks for any pointers. I'm hoping to build a box with every type of scsi interface from ultra2 LVD down to this advansys with an internal 50-pin connector and external 25 pin D-sub connector. I can finally go through all my old scsi hard drives and then actually throw something away!

-- clet
debian is my main squeeze



Reply to: