[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problematic upgrade

On 22/03/12 04:34, Frank McCormick wrote:

Just upgraded my Sid system

Will install 13 packages, and remove 0 packages.
24.6 kB of disk space will be freed
[UPGRADE] acpid 1:2.0.15-1 -> 1:2.0.15-2
[UPGRADE] cups-filters 1.0.5-1 -> 1.0.7-1
[UPGRADE] gir1.2-freedesktop 1.31.20-1 -> 1.31.22-1
[UPGRADE] gir1.2-glib-2.0 1.31.20-1 -> 1.31.22-1
[UPGRADE] google-chrome-stable 17.0.963.79-r125985 -> 17.0.963.83-r127885
[UPGRADE] libcupsfilters1 1.0.5-1 -> 1.0.7-1
[UPGRADE] libgirepository-1.0-1 1.31.20-1 -> 1.31.22-1
[UPGRADE] libpcre3 8.12-4 -> 8.30-1
[UPGRADE] libpython2.7 2.7.3~rc1-1 -> 2.7.3~rc2-1
[UPGRADE] makedev 2.3.1-89 -> 2.3.1-90
[UPGRADE] python-tk 2.7.1-3 -> 2.7.3-1
[UPGRADE] python2.7 2.7.3~rc1-1 -> 2.7.3~rc2-1
[UPGRADE] python2.7-minimal 2.7.3~rc1-1 -> 2.7.3~rc2-1

Log complete.
Aptitude 0.6.5: log report
Thu, Mar 22 2012 00:02:20 -0400

Be warned...libpcre3 8.30-1 makes for an un-runnable system, at least it
did here. I solved it by downgrading to 8.12-4 again which contains
libpcre.so.3. Apparently the new version doesn't.

I hit the same problem on an upgrade this morning.  I solved it by manually downloading the 8.12-4 deb from the archives (I went to the libpcre3 package page, went to download the latest version but where the list of ftp mirrors appears I copied the link address into my browser.  I then backspaced to remove the package name and get a directory listing so I was then able to find the older package).

I downloaded it and installed with dpkg -i.

I then went into aptitude and found the package there and put a hold on that version.  I was then able to get aptitude to properly re-install desktop-utils (which meant for instance that until that point I was unable to run nautilus).

Alan Chandler

Reply to: