[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

lenovo s205 installation problems

I am trying to install Debian stable (Squeeze, 6.0.4) on a Lenovo
S205, which has an AMD E-350 processor and a 750-Gbyte WD7500BPVT
drive.  The 205 has no internal optical drive, but it does have three
USB ports and one SDHC card slot.

I created a bootable GParted USB flash memory stick.  It booted
successfully, and I used it to partition the drive.

I tried without success to boot the Debian installer from an 8-Gbyte
USB flash memory stick.  I tried two different procedures for creation
of a bootable ROM, but neither worked; the approaches are detailed in:


Finally, I burned a DVD with the first 6.0.4 DVD image, and then I
used a desktop DVD drive with an external power supply and a
SATA-to-USB2.0 adapter (in lieu of a store-bought external DVD ROM).
That approach was successful, and the installation of Squeeze appeared
to proceed normally.  However, the new system would not boot.

I now am searching with Google to resolve several issues, primarily:

(1) The Debian installer defaults to the 2.6-amd64 kernel, but offers
2.6-686 and 2.6-486.  I plan to run mostly XEmacs and TeXLive, but
also IceWeasel for browsing and the occasion YouTube video.  So is
it good to install the amd64 kernel?

(2) The BIOS setup gives two options for "SATA Controller working
mode"; they are AHCI and IDE ("compatible mode").  Some of the
articles I found on this matter recommend IDE mode unless there is a
need for RAID; other articles recommend AHCI unless the OS release
date is pre-2007.  Some articles warn against changing the mode after
installation; at least one article argues to the contrary.  Which mode
should I use?  Is selection of the wrong mode causing the failure of
GRUB to boot?

(3) During installation, the only USB port which appears to be active
is the port feeding the DVD drive.  Aside from the minor inconvenience
of being unable to use a full-size external USB keyboard for the
installation, I am unable to provide "missing firmware" (namely,
"rt1_nic/rt18105e-1fw") on removable media during the installation.

I tried plugging the DVD drive into one USB port and the external USB
keyboard into another USB port, but only the drive was recognized.

Next, I tried plugging in only the external (Logitec) keyboard, but
the S205 BIOS appears not to recognize it, even for navigating the
BIOS screens and menus.

I also tried using an external (powered) USB hub, with the DVD drive
and the external USB keyboard plugged into the hub; the S205 booted from
the DVD drive, but did not recognize the USB keyboard.

If ever I get the machine running Debian, I need an external mouse
(wired or wireless), so I need all of the USB ports to be functional.
What is the key?


Reply to: