[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: can't apt-get update: Could not create a socket for 2001:8d8:580:400:6564:a62:0:2

Thanks Brian,

This has actually nothing to do with ipv6, but with iptables blocking
apt outgoing access. I didnt notice this at first because I hadnt set
this machine up in the first place and i was able to ping internet
addresses as well as the debian mirrors.

Thanks for helping out.


“Free software” is a matter of liberty, not price. To understand the
concept, you should think of “free” as in “free speech”, not as in
“free beer”.

Free software is a matter of the users' freedom to run, copy,
distribute, study, change and improve the software.

On Thu, Dec 1, 2011 at 8:33 PM, Brian <ad44@cityscape.co.uk> wrote:
> On Thu 01 Dec 2011 at 19:32:24 +0100, feralert wrote:
>> Today I tried apt-get updating a debian lenny machine and this is what I got:
>> (more info below)
>> # apt-get update
>> Err http://ftp.es.debian.org lenny Release.gpg
>>   Could not connect to ftp.es.debian.org:80 ( - connect
>> (111 Connection refused)
> Seems clear enough. You're not going anywhere.
> [Snip]
>> Also, no sign of ipv6 in my interfaces:
>> carbeto:~# ifconfig
>> eth0      Link encap:Ethernet  HWaddr 00:26:55:d0:d5:08
>>           inet addr:  Bcast:  Mask:
>>           UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
>>           RX packets:6063410 errors:0 dropped:0 overruns:0 frame:0
>>           TX packets:8474925 errors:0 dropped:0 overruns:0 carrier:0
>>           collisions:0 txqueuelen:100
>>           RX bytes:532197429 (507.5 MiB)  TX bytes:2988141460 (2.7 GiB)
>>           Memory:fbfe0000-fc000000
> Mine. Also on Lenny.
>  eth0      Link encap:Ethernet  HWaddr 00:11:2f:f6:41:c3
>            inet addr:  Bcast:  Mask:
>            inet6 addr: fe80::211:2fff:fef6:41c3/64 Scope:Link
>            UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
>            RX packets:5377334 errors:0 dropped:0 overruns:0 frame:0
>            TX packets:3428088 errors:0 dropped:0 overruns:0 carrier:0
>            collisions:0 txqueuelen:1000
>            RX bytes:399530548 (381.0 MiB)  TX bytes:322687720 (307.7 MiB)
>            Interrupt:17
> No ipv6 here.
> [Another snip]
>> I have other machines with lenny in other offices and all apt-get
>> update just fine, I also tried copying a sources.list file from one of
>> the working ones to no avail.
>> Any idea why this is happening?
> If it has worked before but is not working now leave it for a day or so
> and try again.
> What is is your /etc/hosts?
> --
> To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
> Archive: [🔎] 20111201193305.GE3655@desktop">http://lists.debian.org/[🔎] 20111201193305.GE3655@desktop

Reply to: