[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Corrupted security update package files

Bill Wohler wrote:
> When updating lenny this morning (yes, upgrading is on my todo list), I
> got the following error:
>     E: Problem with MergeList /var/lib/apt/lists/security.debian.org_dists_lenny_updates_main_binary-i386_Packages
>     E: The package lists or status file could not be parsed or opened.
>     E: Couldn't rebuild package cache

The problem is the upstream security.debian.org archive's
/dists/lenny/updates/main/binary-i386/Packages file.  It is
corrupted.  It contains the following in the middle of the file.  I
include "..." to signify several lines.  The rest is verbatim.

  Package: sndfile-programs
  SHA256: 18f3af14bda44dc71bd16474d78856b249d7392e2fa8bd93a548f3cdd689b947




  Package: libthai-data

In the upstream file between those two package file paragraphs are
three corrupted package paragraphs.  None of those "None" lines should
be there.  It will need to be fixed in the security archive.  I am
sure a fix will come through quickly.


Attachment: signature.asc
Description: Digital signature

Reply to: