[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

(SOLVED) Re: Upgrading from Lenny to Squeeze

On 11/30/11 04:52, Stephen Powell wrote:
On Wed, 30 Nov 2011 01:35:21 -0500 (EST), Marc Shapiro wrote:

The problem was that the /etc/uswsusp.conf file (used by s2disk and
s2both) still had the old swap file listed as the resume device.
Correcting that and then updating the initrd seems to have solved the
problem.  At least the system fully boots without requiring any
intervention.  Unfortunately, s2disk does not work.  When I try (as
root) to run s2disk I get the 'Can not stat device...' message then.
Unless I can get this working really soon I am probably just going to
uninstall uswsusp as I have never used it in the past and don't see much
need for it on a desktop system that is usually up 24/7.

Excellent!  How were you able to figure this out?  I have no experience
with s2disk.  I don't have it installed, and I've been running Desktop
Debian systems for a long time; so you don't need it.

Google is your friend! I don't remember exactly what my search terms were, but the top item gave me the answer (once I read down through all the answers that were less than useful to me, or the OP of that thread).

I have already deleted the uswsusp package, as well as /etc/initramfs-tools/conf/resume and /etc/initramfs-tools/conf/driver-policy (since they weren't on my system before). I then rebuilt the initrd and rebooted. All is now good in the world, at least as far as my boot and swap problems are concerned.


Reply to: