[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: nvidia binary drivers to get glx and xorg 1.11.0 on sid



On Fri, 23 Sep 2011 16:16:38 -0400, Mitchell Laks wrote:

> I have  been using the nvidia binary drivers
> NVIDIA-Linux-x86_64-173.14.25-pkg2.run
> NVIDIA-Linux-x86_64-173.14.30-pkg2.run
> NVIDIA-Linux-x86_64-173.14.31-pkg2.run
> 
> on my desktop running sid.

Those are very old nvidia drivers :-?

> Recently with the upgrade to linux kernel linux-image-3.0.0-1-amd64
> 
> I found that I had difficulty compiling nvidia drivers against 3.x
> kernels 

What error you got?

> and additionally I found that the current stable and beta nvidia
> drivers wont run with the current sid xorg version 1.11

That's something to report to nvidia or xorg guys...

> I have tried to go back to the older stable kernel
> 
> linux-image-2.6.32-5-amd64

Old stable kernel is 2.6.39-x, or at least that's what I have in wheezy.

> but when I try to compile I find that the gcc-4.3 that was used to
> compile the kernel which is neccessary to compile the nvidia drivers
> against the linux-headers linux-headers-2.6.32-5-common
> has been removed from sid since it conflicts with libgcc1.

Try to find whatever you need from the snaphot archive.

> I guess I have to compile my own kernel 2.6.32 kernel from source using
> a more recent gcc.
> 
> but what to do about the xorg version and not running against 1.11?

I read something about this yesterdy, it was in the changelog:

http://packages.debian.org/changelogs/pool/non-free/n/nvidia-graphics-drivers/nvidia-graphics-drivers_280.13.really.275.28-1/changelog

Maybe you only have to wait?

> unfortunately kernel.org is down. where can i get the older kernel
> sources. any other ideas?

I asked a similar question and I was told to download kernel sources from 
here:

https://github.com/torvalds/linux/downloads

Greetings,

-- 
Camaleón


Reply to: