[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: fstab has "user" option, but still cann't be mounted by non-root user

On Thu, 08 Sep 2011 21:43:33 +0800, yuanwei xu wrote:

> Hello, below is one section of my fstab, I want my usb
> harddisk(/dev/sdbx) can be mounted by the non-root,according the man
> page of fstab,I set the "user" option,but still get error " mount: only
> root can do that" when i try to mount it.
> # /etc/fstab: static file system information. 
> #
> # <file system> <mount point>   <type>  <options>       <dump>  <pass> 
> # /dev/sdb4       none            ext4    sw              0       0
> UUID=e2f1534d-aecd-4f2a-a153-822ac4d73967	/media/usbdisk4_data    ext4    user,exec,dev,suid,rw,noauto              0       0

By using "noauto" the volume has to be manually mounted, is that right?

> i tried the command: $mount /dev/sdb4 /media/usbdisk4_data and $mount
> /dev/disk/by-uuid/e2f1534d-aecd-4f2a-a153-822ac4d73967
> /media/usbdisk4_data, but both were failed. 


It should be just:

mount -U "e2f1534d-aecd-4f2a-a153-822ac4d73967"

What error are you getting?

Also, remember that the mount point should have the proper permissions:

ls -l /media

And now that I think, not sure if "/media" is a good place to put a 
"statically" mounted volume, I would better create a dedicated mount 
point outside that folder for such purpose.



Reply to: