[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: weird "sleepmode" with via vt6102 and wheezy

On 30/08/11 16:38, Eike Lantzsch wrote:

I got an older motherboard with embedded VIA VT6102 network controller which
I'm using as a print server with cups.
It worked well with squeeze and also OK when I first moved to wheezy.
Something however happened with later updates. Unfortunately I didn't realize
actually with which upgrade this actually happened because I attributed it to
a hardware failurev at first.
Oh, yes, what's the problem?

Well, the network controller of the box goes to sleep during longer
inactivity. The pertinent LED on the switch goes off.
That happened with kernel 2.6.39 and now still keeps happening with 3.0.0.
In the morning just one keystroke is enough to bring the network controller
back to work. The box does not hang. It's just the network connection.
It does not happen every night. I tried ping -t 60 from that box to another
machine, thinking that this might keep up the network connection, but it
didn't turn out that way. The activity obviously HAS to be on the keyboard -
not the network.
This is awkward because I'm not always personally close to that box.

I perused through the BIOS but couldn't locate any setup which lets me
configure this unwelcome sleepmode.
I couldn't figure out if there was some sleepmode introduced into the via-
rhine driver at some moment.

This problem seems to be rare because Google didn't come up with anything
closely resembling this problem.

Any ideas?

This is very interesting.

I've been having similar problems on two systems with the same network controller, but initially thought it was a problem with the onboard SATA controller. Disabling the onboard controller and putting in a PCI SATA card seemed to help, but not completely fix the problem.

I also found that the systems sometime hung randomly during the boot sequence and would only continue if I pressed a key. This is a real problem with one of the PCs, which normally runs headless with no keyboard. I've made a temporary fix with a small circuit that emulated the shift key being pressed every 5 seconds.

Out of interest, what MoBo are you using? Mine are Abit KV7.


Reply to: