[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

GLX Missing

Hello list,

I am unable to get 3d graphics on my laptop.  I've tried the standard
reinstall xserver-xorg, xserver-xorg-video-intel, dpkg-reconfigure, and
then restart, but it hasn't worked.

My video card:

$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Core Processor
Integrated Graphics Controller (rev 18)
$ lsmod | grep -w video
video                  17707  1 i915
thermal_sys            17949  3 video,processor,thermal

So far, so good.  But...

$ cat /var/log/Xorg.0.log | grep -i glx
[   659.592] (II) LoadModule: "glx"
[   659.592] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[   659.599] (II) Module glx: vendor="NVIDIA Corporation"
[   659.599] (II) NVIDIA GLX Module  280.13  Wed Jul 27 17:12:07 PDT
[   659.599] (II) Loading extension GLX
[   659.841] (EE) Failed to initialize GLX extension (Compatible NVIDIA
X driver not found)

To me, it looks like Xorg is trying to load nvidia's glx modules, but
is (correctly) unable to do so, because it (correctly) can't find any
nvidia video cards on my system.  It also seems that this is blocking
Xorg from loading intel glx drivers.

Thanks for any advice,


Reply to: