[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Flash in 64-bit environment

On Thu, Jul 14, 2011 at 08:52:15AM +0200, Lorenzo Sutton wrote:
> Camaleón wrote:
> > On Wed, 13 Jul 2011 17:41:45 +0100, Tony van der Hoff wrote:
> >> I have recently installed Squeeze AMD-64 on my new Phenom box. Generally
> >> very pleased with it, but am having trouble with some Flash files.
> > (...)
> >> Any suggestions as to what to do, please?
> > Yes, you can install Adobe Flash player plugin from either Debian's non-
> > free repo or Adobe's site.
> >
> > Caveat: 64-bits Adobe Flash is plenty of security bugs :-/
> And it also is quite buggy on much flash content (e.g. audio stuttering
> problem). I ended up installing the 32 bit version and it seems to be
> the less-awful one (as much as flash can be non-alwful).

The audio stuttering is down to an incompatibility with recent the
libc6. The behaviour of memcpy in a certain situation was undefined and
has changed. To 'fix' the problem, run
"LD_PRELOAD=/usr/lib/x86_64-linux-gnu/libc/memcpy-preload.so <your
browser>" and your audio should work again.

Paul Saunders

Attachment: signature.asc
Description: Digital signature

Reply to: