[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: GRUB failure

Bret Busby Ask:


I have a "laptop" computer with winXP Pro, Unbuntu 8.04 and Debian 5 (I think it is 5), installed.

With a recent electricity supply failure, I ran an orderly shutdown on
the computer.

Since that shutown, each time that I reboot the computer, it takes me to
the GRUB prompt (rather than the GRUB boot menu), and
I cannot boot the computer into any operating system.

How do I get GRUB to configure itself, to detect the installed operating systems so the computer is usable once again?

Or, has GRUB destroyed the software build of the computer, and all of the data, requiring a complete reinstallation of all of
the operating systems installed on the computer?



Most likely your system is fine, just Grub is having issues finding you OS's. I have had this issue a couple times recently on my Testing install after upgrades, I figure in my case it's due to having 5 h.d.d's

But more to the point. You boot and get


Prompt, right?

I am tired so you may have to do a little research to get your commands straight, but if you boot a live distro, say a current KNOPPIX disk, it should load with GUI and all.

In shell:


#blkid (or equivalent to identify your BOOT os's hdd and partition)

Mount that drive somewhere, example:  /mnt/root

#chroot /mnt/root

#grub-install (man or --help  for triggers, I forget them all, will have to at lest define drive and partition to install to, example: (hd0,1)

If grub install errors out and says something about not finding /dev or somesuch you can exit out of the chroot and

#mount --bind /dev /mnt/root/dev


#chroot /mnt/root

I have gotten the /dev error a couple times before, could have to bind /proc, /sys, or others. But in my experience only do so if grub-install complains about not being able to find that specific directory.

I know this reply is kinda spliced but I'm in middle of working 24+ hours in a day and half. I waited to see if anybody else would form a clean answer, but nothing yet. so I tried.


Reply to: