[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problems installing grub/lilo with RAID1 on /

Tom H <tomh0665@gmail.com> writes:

hello Tom, 

> On Sun, Jun 5, 2011 at 3:30 PM, Felix Natter
> <felix.natter@smail.inf.fh-brs.de> wrote:
>> I am trying to install squeeze (from live DVD[1]) with a RAID1 root
>> filesystem (/dev/md0).
>> There is an error when running grub-install:
>> Jun 5 18:38:18 grub-installer: error: Running 'grub-install --no-floppy --force "/dev/sda"' failed.
>> I tried to run it manually:
>> chroot /target grub-install --no-floppy --force /dev/sda
>> /usr/sbin/grub-probe: error: no such disk.
>> Auto-detection of a filesystem of /dev/md0 failed.
>> Please report this together with the output of "/usr/sbin/grub-probe --device-map=/boot/grub/device.map --target=fs -v /boot/grub" to <bug-grub@gnu.org>
> Does "/target/etc/mtab" exist and is it correct?

Seems like it's correct:
/dev/md0 / ext3 rw,relatime,errors=remount-ro,data=ordered 0 0
tmpfs /dev tmpfs rw,relatime,mode=755 0 0
none /proc proc rw,relatime 0 0

>> chroot /target /usr/sbin/grub-probe --device-map=/boot/grub/device.map --target=fs -v /boot/grub
>> /usr/sbin/grub-probe: info: the size of hd0 is 488397168.
>> /usr/sbin/grub-probe: info: the size of hd1 is 488397168.
>> /usr/sbin/grub-probe: info: changing current directory to /dev.
>> /usr/sbin/grub-probe: info: changing current directory to mapper.
>> /usr/sbin/grub-probe: info: opening md0.
>> /usr/sbin/grub-probe: error: no such disk.
> On both Debian and Ubuntu, I used to be able to run "dpkg-reconfigure
> grub-pc", choose md0, sda, and sdb, and grub would be installed on all

This results in the same error.

> three. For a while now (I can't remember for how long), installing to
> md0's failed.

Is this a known bug or unsupported?

>> When trying to install lilo (with the debian-installler), I get
>> "inconsistent raid information" (but the RAID1 (2x 208G) was created
>> with debian-installer):
>> Jun 5 19:22:00 in-target: Running lilo...
>> Jun 5 19:22:01 in-target: Fatal:
>> Jun 5 19:22:01 in-target: Inconsistent Raid version information on /dev/md0  (RV=0.90 GAI=1.2)
> What do RV and GAI mean? I've googled both and not foudn anything to
> help. "0.90" and "1.2" are mdraid metadata versions. Were these disks
> previously in another array and do you now have two types of metada on
> them?

No, I did not change any hardware config before reinstalling with
squeeze. I also had a RAID1 root fs with those two disks before.

I think it is justified to file a bug against debian-installer.

Felix Natter

Reply to: