[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

consolekit makes trouble

Hello list, 

I am really despaired! Due to a defective RAM, my /usr was corrupted, and so I 
had to reinstall the system from scratch. I installed debian/testing 
completely new (except /home, which is on a separate partition). As I am 
courious, I saved my package list by dpkg --get-selections > package.txt, and 
after the fresh installation, I could reinstall them again. I did this with 
the command: apt-get install $(cut -f1 package.txt), which worked fine.

But after that, I got a problem, and now working for hours to solve it:

As I am using kdm (and kde), I get an error:

kdm: :0[21175]: Cannot open ConsoleKit session: Unable to open session: Failed 
to execute program /usr/lib/dbus-1.0/dbus-daemon-launch-helper: Succes

I can click it away, and I can use kde without any trouble.

Ok, to see, what hapend, I examined the log and found more information: 

May 29 09:33:43 localhost console-kit-daemon[22438]: WARNING: 
polkit_authority_get: Error getting authority: Error initializing authority: 
Error calling StartServiceByName for org.freedesktop.PolicyKit1: 
GDBus.Error:org.freedesktop.DBus.Error.Spawn.ExecFailed: Failed to execute 
program /usr/lib/dbus-1.0/dbus-daemon-launch-helper: Success 

So it looks like, there might be some authorization problem. I googled a lot, 
but found no usefull hints. Somebody solved it, by "unmerging glib-
networking", but that was in gentoo.

I will be very happy, if someone could help me, as I there is not much 
information about consolekit and dbus to find.

Thank you very much for any help.

Best regards

Hans-J. Ullrich

P.S. Sorry, if I sent this wrong, debian-user@lists.debian.org claimed my e-
mail as spam. 

Reply to: