[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Roundcube broken after Squeeze upgrade

Roundcube keeps redirecting to the login page immediately after a successful login. I briefly see the initial mailbox view, then get instantly redirected back to the login page, with some jibberish appended to the back of the URL. Something was apparently broken during the Squeeze upgrade, but, IIRC, the problem didn't start until after I rebooted the machine a couple of days after the upgrade, as I tested all the server apps, including RC, immediately after the upgrade, and they worked.

I was already running RC 0.3.1 via Lenny Backports, so nothing should have substantially changed since the Squeeze pkg is also 0.3.1, except maybe system libraries such as PHP, etc.

Unlike most others I'm using sqlite instead of mysql. I do see some errors such as

[27-Apr-2011 19:15:28] PHP Deprecated:  Assigning the return value of
>> new by reference is deprecated in /usr/share/php/MDB2.php on line 2647

that sorta of point to a possible DB issue, but frankly this aspect of RC is over my head. One RC list member suggested I upgrade PEAR. Another said these errors shouldn't cause the problem I'm seeing. If the Debian devs did their job with version dependencies correctly, and the community tested RC before the Squeeze release, then the Debian RC package should simply work. This leads me to believe something else is borked.

I performed "aptitude remove --purge roundcube" and reinstalled to no avail. Other RC users have run into this problem but only apparently with 0.4.x and 0.5.x. None of the possible fixes they mentioned have worked for me. One such suggestion was to disable the Suhosin module. Suhosin is compiled into the PHP5 shipped in Squeeze so it can't be disabled. If indeed Suhosin is the cause of the problem, then Roundcube should be broken for all Debian 6 users.

Anyone else seen this problem? Anyone have any ideas? My webmail is totally down until I can resolve this.



Reply to: