[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Close: Mac Pro, Debian squeeze install, RAID 5, LVM, but won't boot


I think I'm almost there, but I'm puzzled. I appear to have successfully set up 
RAID 5 and LVM following this page:


I have three 500 GB drives and they are configured like this:
/dev/sda1 is ext4 /boot
/dev/sd[abc]2 are RAID 5 forming the LVM for /usr, /home, /var, /tmp
/dev/sd[bc]1 are RAID 1 ext4 and / (root filesystem)

Maybe this configuration won't work. I tried the instructions on the Debian 
Admin page and had /dev/sd[abc]1 all in RAID 1, but the whole install dumped 
when it got to installing grub. So, I repartitioned and tried the above.

My understanding is that Mac Pro is EFI, so how do I connect that to the linux 
boot process. When I run grub-install in a rescue mode shell, it tells me that 
/boot/grub does't look like an EFI partition.

Is my confusion that GPT is not EFI necessarily? fdisk -l says /dev/sda1 is a 
GPT partition.

Perhaps it won't work.

Any pointers on this will be greatly appreciated. 

Also, I have read the Debian Wiki on installing on this machine, but that 
information sounds a little dated. If I can figure this part out, I may be able 
to add to/update it. This page


says this:

"Mar. 4, 2010, Debian testing on MacBookPro5,1: Installer works, but you might 
have to use dd to blow away the gpt tables from the BOTH the beginning and the 
end of your disk first, if it was once formatted by os x."

I'm not sure what that means either.

Thanks for your time.

Reply to: