[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: Tripwire can't send report by email‏‏



I don't find how to change this "<tripwire@proxytest>" by a FQDN the <tripwire@mydomain.com>
If I try to launch hostname -v, I have the FQDN of my server.
root@proxytest:/etc/tripwire# hostname -f
proxytest.subdomain.mydomain.com

Can I specify the "From address" in twcfg.txt ?
root@proxytest:/etc/tripwire# hostname -f
proxytest.intra.ville-issy.fr

Here my twcfg.txt file

root@proxytest:/etc/tripwire# more twcfg.txt
ROOT          =/usr/sbin
POLFILE       =/etc/tripwire/tw.pol
DBFILE        =/var/lib/tripwire/$(HOSTNAME).twd
REPORTFILE    =/var/lib/tripwire/report/$(HOSTNAME)-$(DATE).twr
SITEKEYFILE   =/etc/tripwire/site.key
LOCALKEYFILE  =/etc/tripwire/$(HOSTNAME)-local.key
EDITOR        =/usr/bin/editor
LATEPROMPTING =false
LOOSEDI RECTORYCHECKING =false
MAILNOVIOLATIONS =true
EMAILREPORTLEVEL =3
REPORTLEVEL   =3
SYSLOGREPORTING =true
MAILMETHOD    =SMTP
SMTPHOST      =localhost
#SMTPHOST      =smtp.altitudetelecom.fr
SMTPPORT      =25

Thank you




From: oneal42@hotmail.com
To: debian-user@lists.debian.org
Subject: Tripwire can't send report by email■■
Date: Sun, 24 Apr 2011 07:28:42 +0000

Hello,

I repost my question because I don't have posted it in the right way. I'm sorry, it's my first post in the Debian mailing list.

I have setup tripwire on a Debian 6. I have tripwire integrity reports (pwr files) in the directory /var/lib/tripwire/report/
With the following command I can read the report.
twprint --print-report --twrfile proxytest-20110421-135326.twr > test-log

I would like send the report by email.

In the file /etc/cron.daily/tripwire
there is the command tripwire --check --quiet --email-report

If I try to launch this in command line I have this message :
root@proxytest:/etc/cron.daily# /usr/sbin/tripwire --test --email toto@mydomain.com
Sending a test message to: toto@mydomain.com
### Error: The SMTP server returned an error.
### Error Number:504 5.5.2 <tripwire@proxytest>: Sender address rejected: need
### fully-qualified address
### Exiting...
Email test failed.

proxytest is the hostname of my server

Do you have an idea to solve this issue ?
I tried to change in the twcfg the variable SMTPHOST by smtp.altitudetelecom.fr (my ISP SMTP relay) instead of localhost. But it doesn't work...

Thank you in advance for your help.

Cedric

Reply to: