[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

FAT: Filesystem panic


I'v got 2 boxes running squeeze and lenny, both up to date. On a box with squeeze, I copied 1.8G images to a 2G flash drive and tried to move them to my lenny box. After mounting a drive (hal) on a lenny box cpu jumped to 100%, and after about 30 secs a new window came up with some weird file names. Here is the output from cmd line:

# ls -l
ls: cannot access =jm°£û≈,.1/¡: No such file or directory
ls: cannot access íz╫ƒuìöm.«/e: No such file or directory
ls: cannot access kε╔┌*╧┘á.?/╧: No such file or directory

dmesg output:

[5372932.625012] FAT: Filesystem panic (dev sdd1)
[5372932.625016]     invalid access to FAT (entry 0x0000f7ab)
[5374942.645072] FAT: Filesystem panic (dev sdd1)
[5374942.645075]     fat_bmap_cluster: request beyond EOF (i_pos 8268)

I tried to mount a drive on a squeeze box, but without any luck. Same weird file names there. I thought I lost my data, but no! It can be accessed from WindowsXP and Mac OS X 10.5.8 Leopard without any problems. Any ideas?

Best Regards,

George Chelidze

Reply to: