[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [OT] compiled kernels do not boot

tv.debian@googlemail.com wrote:
25/03/2011 21:19, Hugo Vanwoerkom wrote:

I have tried 3 self-compiled kernels and they do not boot. They compile
w/o errors.

They are compiled with 'make-kpkg --revision 1 --append-to-version -ck2
--initrd kernel_image'. This is with an uptodate Sid.

I have looked at the initrd files with cpio and I see nothing wrong: the
'init' file is there as it should be, etc. But what to look for?

I use legacy-grub and that just sits there with 'boot' as the last
command, forever.

Does anybody have any suggestions as to what to try next?

I have used make-kpkg many times, but not in the last 5 months, and this
has never happened to me.


Hi, I don't think there is a general problem in kernel-package
(12.036+nmu1 here), I compiled three kernels (2.6.37* and 2.6.38*) this
week and one more is backing right now without issue.

Are the required hooks scripts for your setup in place and valid (see
/usr/share/kernel-package/examples/etc/) ? Any module missing from
/etc/initramfs-tools/modules ?

I did not change the scripts in /etc/kernel. Did you? It has postinst.d
 postrm.d  preinst.d  prerm.d for directories. The latter 2 are empty
and the former 2 have initramfs-tools  pm-utils  zz-update-grub as
scripts and initramfs-tools  zz-update-grub as scripts.

I have not added any module to /etc/initramfs-tools/modules.

Maybe you could try with "make deb-pkg" target and see if it boots this way.

Never used that before. But I ran "make deb-pkg" in the kernel tree and that created a .deb. Installed that and booted that kernel and it behaved exactly the same way: last grub command is 'boot' and it just sits there.


Reply to: