[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

X-windows copy/paste mess

I'm running testing (Wheezy) and am failing to get copy/paste working cleanly
among my most common windows, namely:

  several xterms
  virtualbox running a virtual XP client

The window manager is fvwm.  As far as I can tell, the problem comes down to
  virtualbox only reads from the CLIPBOARD selection.
  iceweasel only reads from or writes to PRIMARY.
  xterms can be configured to work with PRIMARY or CLIPBOARD but not both.

At first, I relied on defaults (PRIMARY), and all copy/paste worked with one
exception: I couldn't paste into virtualbox.  (This had not been a problem
with VMware.)  After reading this:


I added a line to ~/.Xresources:

  xterm*selectToClipboard: true

This makes xterms use CLIPBOARD instead of the default PRIMARY.  After that,
I could copy and paste between an xterm and virtualbox (via CLIPBOARD).  Now,
though, I can't do copy/paste with iceweasel and anything else, probably
because iceweasel uses PRIMARY exclusively.  Adding this to ~/.Xresources:

  iceweasel*selectToClipboard: true

had no effect.

There are solutions posted, e.g.:


I haven't tried to duplicate those yet because they require extra keystrokes
to specify PRIMARY or CLIPBOARD.  I can get from xterm to iceweasel by
creating a cut buffer with xcutsel, but that's too hard.

Is there any way to get all of these programs to use the same selection?  I'd
be happy if xterm could be told to always copy to both PRIMARY and CLIPBOARD,
but it seems you have to pick one or the other.


Reply to: