[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

grub2 not displaying boot menu on serial redirect


I run a headless box in conjunction with serial redirect.

I posted about a year ago in regards to grub2 not displaying the boot menu to the serial output:


Since that post, I'd just waited for upstream to fix the bug, and didn't think much of it.  Grub2 had since then been upgraded, and somehow my problem went away.

Yesterday I ran update-grub, and the problem has resurfaced.  The menu appears on video out, but no longer to the serial.  The boot process redirects to serial just fine (at which point grub hands over control the the kernel iirc).

any advice would be appreciated - below is a snippet of my grub.cfg:

### BEGIN /etc/grub.d/00_header ###
set default=0
set timeout=20
serial --unit=0 --speed=9600 --word=8 --parity=no --stop=1
terminal serial
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/10_linux ###
menuentry "Debian GNU/Linux, linux 2.6.26-2-686.21" {
      set root=(hd0,6)
      search --fs-uuid --set 7abda901-2a56-4917-96af-c6dc983d015c
      linux   /vmlinuz-2.6.26-2-686.21 root=UUID=25ed25b7-64bb-4949-ba5e-932093b1fcef ro console=tty0 console=ttyS0,9600
      initrd  /initrd.img-2.6.26-2-686.21


Reply to: