[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: logcheck


so finally i grepped my whole fs. i found the olddomain in /var/cache/debconf/config.dat, with postfix owner(some main.cf values). what i did, run dpkg-reconfigure postfix. altough i have already changed the domain in postfix, mailname, etc, it showed up the old one. as i changed the domain via dpkg-reconf, it also changed in /var/cache/debconf/config.dat, and now logcheck is sending with the newdomain.

postfix main.cf is identical before dpkg-reconfigure

i can not imagine how can /var/cache/debconf/config.dat affect this!

On 2011.01.19. 18:05, Camaleón wrote:
El 2011-01-19 a las 12:10 +0100, Informatik.hu escribió:

(resending to the list)

On 2011.01.17. 16:04, Camaleón wrote:
On Mon, 17 Jan 2011 14:41:11 +0100, Informatik.hu wrote:

I am using logcheck on my squeeze, i have changed the domain name of the
machine from olddomain.com to newdomain.com, everything works fine, but
logcheck still sends the mails with root@olddomain.com. How/where can i
a change the sender of logcheck emails?
In the configuration file "/etc/logcheck/logcheck.conf" there should be a
variable "SENDMAILTO=" that you can adjust.

But the main question still remains (unless you had manually changed the
default settings of that variable and now forgot to update it ;-P)...

Why e-mails to "root" are not delivered to the current and updated host
domain? Check your alises database ("cat /etc/alisases") and your
hostname (hostname -d).
NOT SOLVED! Still sending with olddomain. I tried to purge and reinstall
logcheck package, but nothing.
Sending "with" or sending "to"?

I'm afraid this is not happening only with logcheck e-mails but all
e-mails that pass through your Postfix server.

Please, send a message to "logcheck" user and review the Postfix log to
see what is going on.


Reply to: