[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

State of interfaces ; was Re (3): error message from openvpn.



Progress.

From:	Bob Proulx <bob@proulx.com>
Date:	Sun, 28 Nov 2010 15:39:20 -0700
> You might crank up the verbosity of the openvpn
> logging and see if it logs something interesting.

root@dalton:~# grep verb /etc/openvpn/my*
verb 9
root@dalton:~# grep tun0 /var/log/syslog
root@dalton:~# grep tun0 /var/log/kern.log
root@dalton:~# ip link show tun0
Device "tun0" does not exist.

Whereas Joule has tun0 in "state UNKNOWN". 
peter@joule:~$ ip link show tun0
6: tun0: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast 
state UNKNOWN qlen 100
    link/none

Even lo is "state UNKNOWN".
peter@joule:~$ ip link show lo
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00

An ne2k-pci NIC as the primary Internet connection also gave "state UNKNOWN".
Whereas an e100 is UP.
peter@joule:~# ip link show MainBoard
4: MainBoard: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast 
state UP qlen 1000
    link/ether 00:03:47:c2:94:65 brd ff:ff:ff:ff:ff:ff

So I've narrowed the problem.
Why no tun0 on Dalton?
Why are some interfaces in "state UNKNOWN"?
Google finds a variety of references to interface "state UNKNOWN"   
but I'm running out of weekend.

Thanks for the help,       ... Peter E.



-- 
Telephone 1 360 450 2132.  7785886232 is gone.
Shop pages http://carnot.yi.org/ accessible as long as the old drives survive.
Personal pages http://members.shaw.ca/peasthope/ .


Reply to: