[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: Monitor detection failure and video display



Some additional info.

I tried this:

Section "Device"
    Identifier     "Device0"
    Driver         "nouveau"
    Option         "IgnoreEDID" "true"
EndSection

But I get this in /var/log/Xorg.0.log (actually I get that error if the IgnoreEDID is there or not):

--------8<---snip---8<--------

(--) NOUVEAU(0): Chipset: "NVIDIA NV98"
(**) NOUVEAU(0): Depth 16, (--) framebuffer bpp 16
(==) NOUVEAU(0): RGB weight 565
(==) NOUVEAU(0): Default visual is TrueColor
(==) NOUVEAU(0): Using HW cursor
(II) NOUVEAU(0): Output DVI-I-1 using monitor section Monitor0
(II) NOUVEAU(0): Output VGA-1 has no monitor section
(II) NOUVEAU(0): EDID for output DVI-I-1
(II) NOUVEAU(0): EDID for output VGA-1
(II) NOUVEAU(0): Output DVI-I-1 disconnected
(II) NOUVEAU(0): Output VGA-1 disconnected
(WW) NOUVEAU(0): No outputs definitely connected, trying again...
(II) NOUVEAU(0): Output DVI-I-1 disconnected
(II) NOUVEAU(0): Output VGA-1 disconnected
(WW) NOUVEAU(0): Unable to find initial modes
(--) NOUVEAU(0): Virtual size is 0x0 (pitch 0)
(==) NOUVEAU(0): DPI set to (96, 96)
(II) Loading sub module "wfb"
(II) LoadModule: "wfb"
(II) Loading /usr/lib/xorg/modules/libwfb.so
(II) Module wfb: vendor="X.Org Foundation"
        compiled for 1.7.7, module version = 1.0.0
        ABI class: X.Org ANSI C Emulation, version 0.4
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/lib/xorg/modules/libfb.so
(II) Module fb: vendor="X.Org Foundation"
        compiled for 1.7.7, module version = 1.0.0
        ABI class: X.Org ANSI C Emulation, version 0.4
(II) Loading sub module "exa"
(II) LoadModule: "exa"
(II) Loading /usr/lib/xorg/modules/libexa.so
(II) Module exa: vendor="X.Org Foundation"
        compiled for 1.7.7, module version = 2.5.0
        ABI class: X.Org Video Driver, version 6.0
(II) Loading sub module "shadowfb"
(II) LoadModule: "shadowfb"
(II) Loading /usr/lib/xorg/modules/libshadowfb.so
(II) Module shadowfb: vendor="X.Org Foundation"
        compiled for 1.7.7, module version = 1.0.0
        ABI class: X.Org ANSI C Emulation, version 0.4

Backtrace:
0: /usr/bin/X (xorg_backtrace+0x3b) [0x80e7aab]
1: /usr/bin/X (0x8048000+0x610e5) [0x80a90e5]
2: (vdso) (__kernel_rt_sigreturn+0x0) [0xb778f40c]
3: /usr/bin/X (InitOutput+0xc80) [0x80b8e80]
4: /usr/bin/X (0x8048000+0x1e79b) [0x806679b]
5: /lib/i686/cmov/libc.so.6 (__libc_start_main+0xe6) [0xb74d0c76]
6: /usr/bin/X (0x8048000+0x1e541) [0x8066541]
Segmentation fault at address 0x18

Fatal server error:
Caught signal 11 (Segmentation fault). Server aborting


Please consult the The X.Org Foundation support 
         at http://wiki.x.org
 for help. 
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

Reply to: