[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: slapd stopped working...

On Jul 16, 2010, at 12:39 PM, Troy Telford wrote:

I'm running sid; there was a couple of recent updates to slapd, from 2.4.21-1 to 2.4.23-1 (and then 2.4.23-2)

The config itself wasn't changed; the backup file made is the same as the current one.

However, slapd doesn't start anymore.

All I have to go on is the following:
Jul 16 12:26:53 pilot slapd[7441]: auxpropfunc error invalid parameter supplied
Jul 16 12:26:53 pilot slapd[7441]: _sasl_plugin_load failed on sasl_auxprop_plug_init for plugin: ldapdb

and the following from syslog:
syslog.0:Jul 15 23:04:29 pilot slapd[3050]: @(#) $OpenLDAP: slapd 2.4.23 (Jul 15 2010 19:20:59) $ ^Iroot@monster:/tmp/buildd/openldap-2.4.23/debian/build/servers/slapd

From what I've looked at for the auth.log, that error isn't a fatal one; slapd isn't/can't use the plugin anyway.

But it is disconcerting to have slapd stop working entirely, with zero config changes on my part.

I found the solution:  it was a db version issue.

I did the following:

cd /var/lib
# make a backup just in case...
rsync -aP ldap ldap.org
cd ldap
db4.8_checkpoint -1
chown openldap:openldap *
/etc/init.d/slapd start

And now ldap works again.

Reply to: