[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

wireless (Atheros AR5001) was working on squeeze, then stopped

Hi. I have an HP G60-249WM laptop, and am currently using squeeze for
better wireless support.  (The latest kernel from backports might also
work; but after trying that, I can say it doesn't play well with the
non-free nvidia driver, which I also need.)

After "upgrading" to squeeze, and updating my firewall rules, the
wireless was working at first.  But while browsing the web a couple days
ago, network-manager repeatedly prompted me for my wireless password,
and would not accept the correct one.  Then I tried unchecking "Enable
Wireless", hoping to re-check it later, but it went gray (disabled)!

After asking some questions and being given suggestions on #debian, and
searching the web (with my wired connection) for answers, I installed
the lshw and rfkill packages and found the following:

# lshw -C network
       description: Ethernet interface
  *-network DISABLED
       description: Wireless interface
       product: AR5001 Wireless Network Adapter
       vendor: Atheros Communications Inc.
       physical id: 0
       bus info: pci@0000:07:00.0
       logical name: wlan0
       version: 01
       serial: [MAC address]
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet
physical wireless
       configuration: broadcast=yes driver=ath5k latency=0 multicast=yes
wireless=IEEE 802.11bg
       resources: irq:23 memory:c2000000-c200ffff

# rfkill list
0: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: yes

If I have read the top Google result for rfkill [1] correctly, this
means that the problem cannot be fixed by *any* software, and is thus a
hardware issue.  Is that right?

Assuming it is hardware, I have noticed that there is a button with a
little wireless logo LED.  Before I "upgraded" to squeeze, it was always
amber-colored.  Afterward, it was usually blue, but blinked between both
colors while I was browsing the web.  Now it is always blue.

I have tried pushing this button once, briefly; several times, quickly;
and holding it down for 30 seconds.  I have also tried every Fn-FXX key
combo from F1 to F12, and some combinations of these with the wireless
button.  No change.

I have also tried the Ubuntu LiveCD; it seems to have the same problem.
And I've tried removing network-manager, manual configuration and
ifdown/modprobe/ifup, and the alternative manager wicd.  None worked.

For additional reference, here's the information provided by ifconfig -a
and iwconfig:

# ifconfig -a
wlan0     Link encap:Ethernet  HWaddr [MAC address]  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

# iwconfig
wlan0     IEEE 802.11bg  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=off   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off

So, is my wireless card fried?  Or what other information is needed to

[1] http://www.mjmwired.net/kernel/Documentation/rfkill.txt

Reply to: