[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Fwd: interesting installation problem - ordering of package initialization routines


I've just come across an interesting problem that highlights an interesting not-quite-but.

The short form (the longer form follow below):

- just installed xen (for virtualization) and DRBD (for disk replication in support of high availability) -- xen virtual machines run "on top of" DRBD-backed block devices

- the Debian packaged versions of xen and DRBD install init routines in /etc/init.d and /etc/rc<n>.d - BUT... they name/number the Snn files such that xen VMs load before DRBD initializes -- i.e., the virtual machines can't find their disks and fail to come up

I fixed the problem simply by changing the order of initialization, but... this leads to an interesting question: How, and to whom to I report this as a bug? It's not a problem with one package, but a problem with interactions between two packages, and it's not clear if it's a problem with Debian packaging or with the upstream packages.

Miles Fidelman

-------- Original Message --------


I've been building up a new HA system, running Xen on DRBD devices.

Configuration this applies to:
Debian Lenny
xen-linux-system-2.6.26-2-xen-686 package


As I've been building the system, I ran into an interesting problem,
with two symptoms:

1. running VMs would come back up after a reboot, but would hang on
simple tasks

2. non-running VMs, set up for auto-start at boot, would not come up

Turns out, that after pouring through a lot of log files, it became clear what was happening - as confirmed by a quick look in to /etc/rc2.d (DomO):

server2:/etc/rc2.d# ls
README	    S16ssh	      S20xend	     S70drbd	   S99rmnologin
S10rsyslog  S20exim4	      S21xendomains  S75heartbeat  S99stop bootlogd
S12acpid    S20openhpid       S23ntp	     S89cron
S12dbus     S20smartmontools  S25mdadm	     S99rc.local

xendomains was trying to bring up VMs, before drbd devices were initialized - leading to all kinds of weirdness. The domains would try to come up, get through the boot stages, and then hang as soon as they tried to mount root and swap.

Changing S21xendomains to S76xendomains (after both drbd and hearbeat) solved the problem.


This isn't really a bug with any one piece of code - it's a bug in the interaction, specifically in the naming/ordering of the init package.  And I expect that this may be specific to packaging (I'm going to do more digging).  SO WHERE DO I FILE A BUG REPORT?

Miles Fidelman

In theory, there is no difference between theory and practice.
In<fnord>   practice, there is.   .... Yogi Berra

Reply to: