[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Aptitude Error

On Sat, May 01, 2010 at 10:23:12PM +0200, James Stuckey <jhstuckey@gmail.com> was heard to say:
> On Sat, May 1, 2010 at 10:15 PM, Daniel Burrows <dburrows@debian.org> wrote:
> >   That's the problem -- you have no (active) "deb" lines for unstable,
> > so apt doesn't know which packages are from it.
> The aptitude search ~Aunstable appears to just list all the packages in the
> repository. As so with the other commands. The list of packages is so long
> that gmail freezes when I try to past it in, and paste.debian.net tells me
> that it is over 90kb and cannot be pasted.

  If you modified sources.list to include unstable, that's exactly what
"search ~Aunstable" should do (it prints every package in unstable,
which is pretty much all of them).  I don't know what to expect from the
?narrow() version, but if most versions are the same in testing and
unstable, you could get a very long printout with that too.


Reply to: