[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: What prevents mounting of USB devices?

Hash: SHA1

Florian Kulzer wrote:
> On Sat, Apr 10, 2010 at 19:20:42 +0200, Clive McBarton wrote:
>> I run KDE and normally mount usb devices with the "Storage Media" applet
>> in the task bar. Recently I have been getting strange errors and
>> mounting failed:
> Which version of KDE, 3.x or 4.x? (I don't remember a task bar applet
> for mounting removable media from my KDE 3.x days - I always triggered
> mounting via the icons that appeared on the desktop for removable media
> - but I might simply not know about alternatives.)

3.x, Lenny default. Probably 3.5.10 if I see correctly. The task bar
applet is called "Storage Media" or "Media Applet". The right-click
options in the taskbar are "Move Storage Media", "Remove Storage Media",
"Configure Storage Media", "About Storage Media". When I bring up its
preferences it has different ideas about its name and now says "Media
Applet Preferences - KDE Panel". The "About" says "using KDE 3.5.10".

> Mounting worked for you earlier, so I assume that your users are all
> members of the "plugdev" group already. 

Yes they are.

> I would like to see the output of:
>   awk '/<policy group="plugdev">/,/<\/policy>/' /etc/dbus-1/system.d/hal.conf


  <policy group="plugdev">
    <allow send_interface="org.freedesktop.Hal.Device.Volume"
    <allow send_interface="org.freedesktop.Hal.Device.Volume.Crypto"

By looking at the modify time, I see that this file has not been
modified since I installed Debian, so it must still be in the default state.

> It would be interesting to know if regular users can mount USB sticks
> using pmount or pmount-hal on the command line. 

Good idea. I never used pmount before. I just tried it with one user
(insert USB stick, pmount it as the user) and it works. Thanks!

Meanwhile, the KDE applet would not have worked, it does not even
display an icon indicating that the USB stick has been plugged in at all.

>> And the UUID of the usb stick is even listed in /etc/fstab so that it is
>> supposed to mount automatically when plugged in (though that does not
>> seem to work). But that may be an unrelated issue.
> AFAIK, you should not have any entries in fstab for removable devices
> that you want to be handled by KDE/Gnome/whatever_other_DE via the
> dbus/hal mechanism. In any case, I would avoid trying to mix different
> approaches.

I would avoid that too, if any single one of them would work, but
neither did. I did not try pmount so far, that would actually have worked.

>> Another (possibly also unrelated) issue is that when several X are
>> running (different users, all with KDE) then it seems that only one of
>> them can mount and unmount, usually the wrong user.
> I have seen that complaint before, also for systems on which mounting
> worked perfectly for single-user sessions, and I am not sure if a
> satisfactory solution exists. (I have no need for running multiple KDE
> sessions on the same machine, therefore I do not know much about this
> issue.)

That is why I made the fstab entries, so I can write the correct user in
it, in the case when a certain device is known to belong to a particular
user. I was hoping that they could mount it then.

>> Is it worth digging into hal to correct this? Given that hal won't be in
>> Debian much longer.
> Well, it is a problem for you right now, so why not try to solve it?
> Besides, udisks has the same main developer as hal, so I doubt that it
> will be so radically different that hal know-how will become useless. I
> have played around a bit with udisks yesterday, it seems to follow the
> same basic concepts as hal. AFAICT, udisks-daemon is simply an upgraded
> version of hald that is specialized on block devices, as one part of a
> more modular approach to hardware abstraction.

Good to know. So far, I was always staying far away from hal for fear of
completely wasting my time. But if hal knowledge will still be useful
after hal is gone, that makes me reconsider.
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


Reply to: