[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: shouldn't apt-get upgrade, you know, upgrade ?

On Tue, 06 Apr 2010 06:50:37 +0200
Johan Grönqvist <johan.gronqvist@gmail.com> wrote:

> My first guess:
> Perhaps you did not quote enough text from the man page?
> [From the text on upgrade]
>             New versions of
>             currently installed packages that cannot be upgraded
> without changing the install status of another package will be left
>             at their current version.

That was a very good guess.
> As ooffice is a rather complex package, it seems plausible to me that
> a new version would require other packages to be installed as well,
> and upgrade is not bold enough to do that.

it does seem plausible, doesn't it ? :-)

> I think you may be interested in the dist-upgrade command instead.

I thought of that, but I thought it was for going from stable to
testing, or a similar sort of thing.  The man page tells all !

dist-upgrade in addition to performing the function of upgrade,
           also intelligently handles changing dependencies with new
versions of packages;

Thank You,


Reply to: