[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

postgresql installation error

I recently upgraded from lenny to squeeze on a 2GHz AMD based HP computer. It mostly went well but during the upgrade process and any time I run dpkg, aptitude or synaptic it gripes about postgresql.

A specific example of it is:

dpkg --configure -a
Setting up postgresql-8.4 (8.4.1-1) ...
insserv: script postgresql-8.4: service postgresql already provided!
insserv: exiting now!
update-rc.d: error: insserv rejected the script header
dpkg: error processing postgresql-8.4 (--configure):
subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of postgresql:
postgresql depends on postgresql-8.4; however:
 Package postgresql-8.4 is not configured yet.
dpkg: error processing postgresql (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:

I've tried web searchs and have seen mention of the error but not with regard to postgresql. In the cases I've seen they recommend removing a file, /etc/init.d/hibernate only I have no such file.

I've tried uninstalling / reinstalling postgresql-8.4 to no avail. I've checked the logs (aptitude, dpkg.log and syslog) and see nothing beyond the above info.
Any ideas?

Reply to: