[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Permissions on USB drive unchangeable

Chris Jones wrote:
On Tue, Dec 15, 2009 at 03:41:53AM EST, freeman wrote:
On Fri, Dec 11, 2009 at 01:28:55PM +0000, AG wrote:
worked fine.  Now the permissions have been changed so that I only
have access to the drive but am unable to write to it.  Therefore, I
cannot do back ups nor can I create new directories, etc.

I have tried the usual approach to these kinds of issues, i.e. sudo
chmod -R 0755 /path/to/drive but this has absolutely no effect.  I
am identified as the owner of the drive and as part of the group,
but I cannot change the permissions of this either as root directly
nor using sudo.

Any thoughts on how I can fix this?
Missed this thread.. 

To the OP, have you tried:

$ lsattr -d /path/to/usb/
# chattr -i /path/to/usb/



Hey Chris, Freeman

No I didn't - I nicked the fix from Tixie's recommendation - basically linking the old ntfs-3g driver to pick up the new driver:

    #link /sbin/mount.ntfs-3g /sbin/mount.ntfs

As (again) Tixie notes, it does seem to be a bug, and those affected appear to be using Gnome under either testing or sid.  The trick seems to work, but am not sure what happens when it gets fixed. 

Thanks for your follow up guys!


Reply to: