[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [SOLVED]Re: Problems with adobe-flashplugin

Frank McCormick:
> Sjoerd Hiemstra:
> > Frank McCormick:
> > > [...] state...strangely enough it's in a file called "status" :)
> > > I hesitate to reveal this but what I did was open the file,
> > > removed the adobe-flashplayer info..and resaved. Problem
> > > gone...aptitude is now happy and will do whatever I ask (except
> > > make the coffee). I know this is what would be considered brute
> > > force...but in my case it worked. I DO NOT recommend it to anyone
> > 
> > Anyway, I can confirm that it worked here, having had the same
> > problem with package python-apt.... problem gone!  :-)
> > 
> > BTW, a new entry for python-apt appears to have been entered in
> > /var/lib/dpkg/status; it looks OK.
>   It's the first time I've had to do anything this drastic with Debian
> but it seemed the only way of getting back on track.  Glad it worked
> for you as well. Hope our machines don't blow up :)

Previously, the entry in /var/lib/dpkg/status for the package in
question had this line:

    Status: install reinstreq half-configured

In the new entry, this line has changed to:

    Status: install ok installed

And that's the only essential difference between the old & the new
It looks like aptitude is not able, at the moment, to recover a package
from that 'half-configured' state.
I guess the problem was caused by some accidental hitch during

Reply to: