[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: stuffed up rc0.d

On Sat, Oct 24, 2009 at 2:02 PM, Alex Samad <alex@samad.com.au> wrote:

> On Sat, Oct 24, 2009 at 01:40:52PM +0200, Tom H wrote:

>> On Sat, Oct 24, 2009 at 7:20 AM, Alex Samad <alex@samad.com.au> wrote:

>>> Some how my /etc/rc0.d is stuffed up, such that when I reboot/shutdown
>>> my partitions don't get unmount and other things don't happen.
>>> with the new insserv how can I go about rebuilding rc0.d ?

>>> can I just do a insserv /etc/init.d ?

>> Moved the contents of rc0.d out
>> Ran insserv -dv /etc/init.d
>> And rc0.d was repopulated.
>> I also tried without the "d" but it was not enough.

> tried that zip -m ~/saved /etc/rc0.d/ ; insserv -dv /etc/init.d

> it talked about creating all the other run levels, but nothing in rc0.d

> so i unzip the saved file and ran it again, it removed all the S level
> items.

> Something strange going on

Definitely strange.

Re-did it:
rm /etc/rc0.d/*
insserv -dv /etc/init.d

All the messages were about rc0.d and rc0.d was repopulated.

Could your init.d files be at fault?!

Reply to: