[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Inconsistency with Debian 5 and adding printers

On Thu, 17 Sep 2009, Florian Kriener wrote:

On Thursday 17 September 2009 06:31:36 Bret Busby wrote:
I have a Samsung CLP300 colour laser printer.

When I connected it to my laptop, in each of both Ubuntu 8.04 and
Debian 5, which was installed as a clean install, the printer was
automatically installed and set up (I didn't have to do anything - it
just appeared as an installed printer, ready to use).

When I connected the printer to this desktop computer, the same
 happened with the Ubuntu 8.04 installation.

When the printer was connected to this desktop and the desktop was
running Debian 4, the printer (apparently) could not be installed.

So (and, for other reasons), I yesterday upgraded the Debian
installation on this computer, to Debian 5, following the Release
 Notes instructions. The only problem of which I was aware, in the
 upgrade, that was encountered, was the loss of the graphics adaptor
 driver, and thence XWindows, which was subsequently, easily (after I
 was advised of the solution), ovbercome.

But, I cannot install the printer driver on this Debian 5

The printer was not automatically installed and set up, ready to go,
 as it was with the clean installation of Debian 5 on the laptop.

In trying to manually install the printer, using the foomatic-gui
application, that application detects the printer, and, goes through
the (apparent) process of installing the printer, but, at the end of
that process, when it should have successfully completed, the printer
 is not added as an installed printer. I have tried adding the
 printer, via the foomatic-gui application, using both the splix and
 the foo2qpdl driver options, and, until the final screen appears,
 that lists the installed printers, shows that the printer is not
 installed, it all seems to be going okay.

I have also tried to add the printer to the installed printers, using
the System -> Administration -> Printing -> Add Printer facility,
 but, whilst that detects the printer, the printer driver is not
 listed as an available printer driver, to select.

Why is it, that a clean install of Debian 5, automatically installs
 and sets up the printer, ready for use, like Ubuntu 8.04, but, a
 Debian 5 installation that is done as an upgrade from Debian 4,
 still disallows the printer from being installed.

Can this be overcome?

At present, I have to revert to doing what I was doing before
 upgrading the Debian installtion on the desktop, to Debian 5; if I
 want to print, using the CLP-300, I have to reboot into Ubuntu 8.04,
 as the Debian installation again does not allow the use of the

It is frustrationg, that a Debian 5 installation, that is done by
upgrading from Debian 4, is so different to a Debian 5 installation
 that is done as a clean install, meaning that a Debian 5
 installation that is done as an upgrade from Debian 4, is more of a
 combination of Debian 4 and 5 (like a system that is a combination
 of stable, testing and unstable), than a Debian 5 system, and is
 thus, not truly Debian 5.

I had intended to add other new printers, including a Samsung
multi-funtion thingy, to my desktop computer, but it appears that a
Debian 5 installation that is an upgrade from Debian 4, does not work
for adding printers, anywhere as well as a Debian 5 installation that
 is done as a clean install, so making it apparently, too much

Responsible for printing is CUPS. Please check if you have it installed
and all packages containing CUPS, that your other machine has installed.
You can get that list with `aptitude "~icups"`.


bret@bretnewworkstation:~$ aptitude "~icups" | less
Unknown command "~icups"
bret@bretnewworkstation:~$ aptitude show cups
Package: cups
New: yes
State: installed
Automatically installed: yes
Version: 1.3.8-1+lenny6
Priority: optional
Section: net
Maintainer: Debian CUPS Maintainers <pkg-cups-devel@lists.alioth.debian.org>
Uncompressed Size: 10.8M
Depends: libavahi-compat-libdnssd1 (>= 0.6.16), libc6 (>= 2.7-1), libcups2 (>= 1.3.8), libcupsimage2 (>= 1.3.8), libdbus-1-3 (>= 1.0.2), libgnutls26 (>= 2.4.0-0), libkrb53 (>= 1.6.dfsg.2), libldap-2.4-2 (>= 2.4.7), libpam0g (>=, libpaper1, libslp1, debconf (>= 1.2.9) | debconf-2.0, poppler-utils | xpdf-utils, perl-modules, procps, ghostscript,
         lsb-base (>= 3), cups-common, ssl-cert (>= 1.0.11), adduser
Recommends: cups-client, smbclient (>= 3.0.9), foomatic-filters, avahi-utils Suggests: cups-bsd, cups-driver-gutenprint, foomatic-db-engine, foomatic-db, hplip, xpdf-korean | xpdf-japanese |
          xpdf-chinese-traditional | xpdf-chinese-simplified, cups-pdf
Conflicts: cupsys (< 1.3.7-6), cupsys-bsd (< 1.3.7-5)
Replaces: cupsys (< 1.3.7-6), cupsys-bsd (< 1.3.7-5)
Provides: cupsys
Description: Common UNIX Printing System(tm) - server
The Common UNIX Printing System (or CUPS(tm)) is a printing system and general replacement for lpd and the like. It supports the Internet Printing Protocol (IPP), and has its own filtering driver model for handling various document types.

 This package provides the CUPS scheduler/daemon and related files.

The terms "Common UNIX Printing System" and "CUPS" are trademarks of Easy Software Products (www.easysw.com), and refer to
 the original source packages from which these packages are made.


Bret Busby
West Australia

"So once you do know what the question actually is,
 you'll know what the answer means."
- Deep Thought,
  Chapter 28 of Book 1 of
  "The Hitchhiker's Guide to the Galaxy:
  A Trilogy In Four Parts",
  written by Douglas Adams,
  published by Pan Books, 1992


Reply to: