[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: SOLVED Re: Sid: Grub2 faling to boot: Unknown device UUID

Curt Howland <Howland@priss.com> writes:

> Just to continue to with the saga, today I decided to just screw it 
> and reintall, to try to install Grub2 first since upgrading from Grub 
> to Grub2 just would not boot.

Yeah, I just ran afoul of the grub-pc "no floppy" bug.

After a fight with the rescue disk, I managed to install the newer
version to the MBR.  I mounted /dev/sda1 as my root, did "mount -a" and
used "/usr/sbin/grub-install '(hd0)'".

Now it pauses and takes an age to show the menu.  Then it takes another
age to start booting the kernel.

> I installed Grub2, with only /dev/hda plugged in so that /dev/hdb 
> would not be formatted since the Debian installer refuses to NOT 
> repartition disks. Fine. With just /dev/hda plugged in, Grub2 booted 
> just fine.

> However, as soon as I plugged /dev/hdb in and tried to boot, Grub 
> choked with "error 2". Whatever that is. I used the rescue function, 
> mounted /dev/hdb1, put it in the fstab, had everything working and 
> executed "update-grub". But it still would not boot, "error 2".
> I tried twice more, Grub and Grub2, no luck. As soon as I plugged the 
> second IDE drive in, Grub would refuse to boot.
> LILO works. So my server is back to using LILO, because GRUB just 
> won't work. I'm sure it's just my server, being old and crotchity, 
> but I'm lost as to why Grub worked last week, before Grub2 installed 
> the UUIDs and messed things up, but Grub doesn't work this week.
> I hate it when that happens. Welcome back, LILO. Long time no see.

Not only does lilo work, but it has documentation and howtos.  Searching
the web for help with grub is an exercise in frustration.  What was grub
supposed to bring us anyway?


Reply to: