[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problem with preseed partitioning

Another update:

Using a different recipe does work.
Instead of the expert_recipe, I used choose_recipe with separate partitions:

d-i partman-auto/method string regular
d-i partman-auto/disk /dev/cciss/c0d0
d-i partman-auto/purge_lvm_from_device boolean true
d-i partman-auto/choose_recipe select Separate /home, /usr, /var, and /tmp partitions
d-i partman/confirm_write_new_label boolean true
d-i partman/choose_partition \
       select Finish partitioning and write changes to disk
d-i partman/confirm boolean true

This seems to work. But I am still not satisfied. Looking further for a solution...

2009/7/1 Andy Kannberg <andy.kannberg@gmail.com>
Hi Eric,

/dev/cciss/c0d0 does exist during install.

I've tried a standard cd install. Then, the root partition takes all space on the device. So it isn't a driver issue. It must be something in the recipe.
So, searching further for a solution. If *anyone* has a tip concerning this matter would be appreciated *so* much !


2009/6/30 Andy Kannberg <andy.kannberg@gmail.com>

Hi Eric,

No, haven't checked the error logs. Will do so tomorrow. I'll post my progress here.



2009/6/30 Eric Gerlach <egerlach@feds.uwaterloo.ca>

On Tue, Jun 30, 2009 at 03:52:36PM +0200, Andy Kannberg wrote:
> Hi guru's,
> I am running into a problem with a system that I want to install via a
> preseed config file.
> All goes well, except the partitioning part. The system I want to install is
> a HP Proliant DL380 G5 with SmartArray.
> For some reason, the recipe I've created isn't used; the installer falls
> back to the standard partitioning scheme.
> I must say, I am installing Ubuntu, but since Ubuntu is Debian based, and
> the Ubuntu maillinglists can't answer my problem, I am trying my luck here.
> The partitioning part of the preseed file is shown below:
> [snip]
> Can someone shed a light on this and help me out what I am doing wrong or
> forgetting ?

It looks good to my eye... keep in mind I've only done this twice.  Have you
checked the error console (VT 4) during install (or the installer log after
install) for errors?

Also, if you drop to a console on VT 2 or 3 during install, does
/dev/cciss/c0d0 exist?

That's all I can think of.  Let me know if you figure it out.


Eric Gerlach, Network Administrator
Federation of Students
University of Waterloo
p: (519) 888-4567 x36329
e: egerlach@feds.uwaterloo.ca

To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: