[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Rsync Insists on Replacing Files

At this point my workstation is an iMac and my server is running Lenny. I've had this happen before, though, with two Linux computers, which leads me to think it's rsync and the issue is OS agnostic.

I have two 1-terabyte RAIDs, one on my server, one on my workstation. In the past this was about what I had, but due to issues that I don't need to go into, essentially the RAID that was on my Debian workstation has been taken down and the drives reformatted for Mac and are hooked up to the iMac via USB. When I did that, I used rsync like this:

rsync -av server::Data /MacRAID/Data/ (Forgot if that one required the "/" at the end or not. Whichever I used, it did copy directly to that directory without creating an extra subdirectory.)

and it copied all the files from the RAID on the server to the RAID on my iMac. Of course they were different user names. In the past I used NIS on my LAN to keep user names the same. Now that I'm done with the setup, the data on the iMac RAID will change more often and the server is essentially a back-up.

Today it was finally time to set up rsync to do regular backups from my workstation to the server, so I tried:

rsync -avn /MacRAID/Data/ me@server:Data (Thanks to H.S. for that help in another recent thread.)

When I do that to do a dry run and see what would transfer, ALL the files in /MacRAID/Data are set to be transferred. Most of these files have not changed at all since I copied them over, with rsync, to the iMac. The only thing that could be different is the owner, but since I'm logging in with "me@server:Data" the files on the server should be in my user name there. I tested with one smaller section and found that they all transferred, all were owned by "me" on the server, just as before -- in other words, there was no visible difference in that directory before I ran rsync and afterwards, but I know rsync replaced all the files with duplicate versions of themselves.

If ownership were an issue, then running rsync again on that directory should cause all the files to be updated again, but it doesn't.

So if the workstation files have NOT changed at all since I copied them to the workstation RAID with rsync from the server, then why is it that now that I'm using rsync to update the newer and changed files, rsync wants to update ALL the files? What is it looking at that it sees as different (the dates are the same)? Is there a way to tell rsync to ignore whatever it sees as different? If there's a way to do that, wouldn't I have to do it every time I update with rsync?

Transferring all the files will take over 24 hours if I have to do that -- that's what it took the first time to copy them to the workstation.

Thanks for any help or insight into this issue!


Reply to: